Answered By: Casey Wallace
Last Updated: May 03, 2017     Views: 26

For any Gale Courses course, you will need Internet access, a non-shared e-mail address, Microsoft Internet Explorer, Google Chrome, Safari or Mozilla Firefox Web browser, and the latest Adobe Flash and PDF plug-ins.

Visit http://www.adobe.com/downloads and click Get Adobe Flash Player and Get Adobe Reader to download these free plug-ins if you do not already have them.

Most of the courses are Macintosh compatible. If a course is not Macintosh compatible, this information will be stated on the course's Requirements tab when you view the course details.

Gale Courses Frequently Asked Questions